Sometimes when you update WordPress or your theme/plugins, all you see after updating is a while screen on the front end, this might happen while doing some customization in the code as well.
Possible Causes
Theme Compatibility
Plugin Compatibility
Server Issues
Custom Code
Troubleshooting Steps
The first thing you can do is enable debug mode on the site to check out what the exact error is. For this, you need to add the following code in wp-config.php file which will be present in the root folder of your WordPress install.
// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
// Disable display of errors and warnings
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );
// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );
This will make a error.log file in wp-content folder which will most of the time show you the exact plugin/theme name which is throwing the error. More information about debugging here https://codex.wordpress.org/Debugging_in_WordPress
For Theme compatibility issues, you need to switch your theme to some other theme from database, you can switch to default WordPress theme using the steps below:
a) Go to PHPMYADMIN
b) Look for WP_OPTIONS table
c) Look for template row in it.
d) Click Edit for the template field
e) In the OPTION_VALUE field, change the theme name to some other theme, it should be same as the folder name of the other theme which you want to use, for example Twenty Seventeen theme, it should twentyseventeen
f)Edit Stylesheet option in that table, just like you edited template field
e)again for stylesheet, give the option_value as the new theme folder name.
This will switch the theme to default theme and site will be loaded again.
2. For Plugin conflicts: You can go to wp-content/plugins folder on hosting file manager and rename the plugin folders to something else and it will deactivate all plugins and you will be able to access the site, then you try enabling them one by one to find out which plugin was conflicting.
3. Server issues if any should be clearly visible in the error log file, you can contact your hosting company with those specific error messages, most of the time, it will be low memory, which can be easily increased by them. You can checkout our article on increasing your memory limit here.
4. Custom code issues will normally not happen if you are modifying the code from WordPress dashboard in new versions of WordPress, if there is problem in the PHP code you are adding, WordPress will not allow changes to be saved. If you are making changes via FTP, try reverting those changes manually.
Note: It is highly recommended to create a complete backup of your website before making any changes.
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