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How to Fix the White Screen Of Death
How to Fix the White Screen Of Death

Learn how to troubleshoot and resolve the White Screen of Death in WordPress to quickly restore your website’s functionality.

Updated over 3 months ago

Encountering the White Screen of Death (WSOD) in WordPress can be alarming and frustrating, leaving your website inaccessible. Various factors, such as plugin conflicts, theme errors, or exhausted memory limits, can cause this issue.

This article will guide you through troubleshooting and resolving the White Screen of Death, helping you restore your website's functionality quickly and efficiently.

Note: It is highly recommended that you create a complete website backup before making any changes.

Possible Causes

  1. Theme Compatibility 

  2. Plugin Compatibility 

  3. Server Issues

  4. Custom Code

Troubleshooting Steps

The first thing you can do is enable debug mode on the site to determine the exact error.

If you can access WordPress Dashboard, you can install and activate the WP Debugging plugin.

If you don't have access to the WordPress Dashboard, you will need to use the cPanel File Manager or an FTP connection and add the following code to the wp-config.php file, which will be present in the root folder of your WordPress install.

 // Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );

// Disable display of errors and warnings
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

This will enable the WordPress debug mode. Any errors will be logged out into the debug.log file, located in the wp-content folder.

This file usually shows the exact plugin/theme name that is throwing the error.

For more information about WordPress debugging, please check the official documentation page.

Theme compatibility issues

You need to switch to another theme to check for issues that might be related to the active theme.

You can switch to the default WordPress theme using the steps below: 

  1. Using an FTP connection or the hosting File Manager app, navigate to the wp-content/themes folder

  2. If the active theme is Divi, rename the folder to something else

Important Notes:

  • Renaming the active theme's folder will force WordPress to switch to one of its default themes.

  • Renaming the active theme's folder will give you access to the WordPress admin area and should also resolve the White Screen of Death.

Plugin Conflicts

  1. Using an FTP connection or the hosting File Manager app, navigate to the wp-content

  2. Rename the plugins folder to something else. Renaming the plugins folder to a different name will deactivate all third-party active plugins, which should grant access to the website

  3. From WordPress Dashboard → Plugins, you can enable one plugin at a time. After each plugin activation, check if the issue is resolved. Repeat this process until the offending plugin is found.

Server-side issues

Server issues, if any, should be clearly visible in the debug.log error log file. You can contact your hosting company with those specific error messages. Most of the time, it will be low memory, which they can easily increase.

You can check out the How to Fix PHP Memory Limit Errors article for more information.

Custom PHP Code

If custom PHP code is added through Apepareance → Theme File Editor and the code has errors, WordPress will block the saving. However, if you are adding/changing the PHP code through an FTP connection, try reverting those changes manually.

Alternatively, you can switch to a better hosting that suits Divi. We recommend Divi Hosting, which is optimized and configured specifically for the Divi Theme and comes with Divi preinstalled. 😄

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